package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.+CPAuth \(.*\:\d+\) response message\: The authentication has failed\, please login again\.$`)
var str = `| 24.03.22 14:11:08.351 MAIN ( PROCESS ) : CPAuth (185.214.223.14:44560) response message: The authentication has failed, please login again.
\`-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}