package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:(HelloWorld:\w*)\(.*?\))`)
var str = `M:HelloWorld:main(java.lang.String[]) (S)HelloWorld:foo()`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}