use strict;
my $str = '000000000000000142
MATERIAL_2';
my $regex = qr/^\d+$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";