import re
regex = re.compile(r"^\d+$", flags=re.MULTILINE)
test_str = ("000000000000000142\n"
"MATERIAL_2")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)