$re = '/^\d+$/m';
$str = '000000000000000142
MATERIAL_2';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;