package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{2})\s(?:(\d{3})\s)?(\d{7,10})`)
var str = `63 240 1234567
63 1234567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}