$re = '/(\d{2})\s(?:(\d{3})\s)?(\d{7,10})/';
$str = '63 240 1234567
63 1234567';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);