$re = '/(?:bower_components\/[\w._-]+)(?=[\/a-zA-Z.]+?)/m';
$str = 'bower_components/bulma.dete-kle_likt/bulma.scss';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);