package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]{3}-([A-Z])-((?:\d+\.){2}\d+-\d+).*?`)
var str = `SDL-A-19.0.0-1-WX-ExP.tar
SDL-B-19.0.0-1-WX-ExP.tar
SDL-C-19.0.0-1-WX-ExP.tar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}