const regex = /^[A-Z]{3}-([A-Z])-((?:\d+\.){2}\d+-\d+).*?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z]{3}-([A-Z])-((?:\\d+\\.){2}\\d+-\\d+).*?', 'gm')
const str = `SDL-A-19.0.0-1-WX-ExP.tar
SDL-B-19.0.0-1-WX-ExP.tar
SDL-C-19.0.0-1-WX-ExP.tar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}