// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[A-Z]{3}-([A-Z])-((?:\d+\.){2}\d+-\d+).*?").unwrap();
let string = "SDL-A-19.0.0-1-WX-ExP.tar
SDL-B-19.0.0-1-WX-ExP.tar
SDL-C-19.0.0-1-WX-ExP.tar";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}