#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((.*? )?(dog|car|house|work|cat)( |$)){3}.*$"
Local $sString = "I always let my cat and dog at the animal nursery when I go to work by car" & @CRLF & _
"The dog jumped over the house to get to work" & @CRLF & _
"The dog and cat are friends" & @CRLF & _
"The dog jumped over the houses to get to work" & @CRLF & _
"This sentence has four consecutive words to match cat dog house car"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")