package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((.*? )?(dog|car|house|work|cat)( |$)){3}.*$`)
var str = `I always let my cat and dog at the animal nursery when I go to work by car
The dog jumped over the house to get to work
The dog and cat are friends
The dog jumped over the houses to get to work
This sentence has four consecutive words to match cat dog house car`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}