$re = '/^((.*? )?(dog|car|house|work|cat)( |$)){3}.*$/m';
$str = 'I always let my cat and dog at the animal nursery when I go to work by car
The dog jumped over the house to get to work
The dog and cat are friends
The dog jumped over the houses to get to work
This sentence has four consecutive words to match cat dog house car';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);