package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:"[^"]+"|[^" ]+)?(\s*)`)
var str = ` apple orange "g r a p e" pear "blue berry" pineapple `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}