re = /(?:"[^"]+"|[^" ]+)?(\s*)/m
str = ' apple orange "g r a p e" pear "blue berry" pineapple '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end