package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\/]*(?:_prd|_trn)`)
var str = `/test/xychcm_prd/test/ss
/test/xychcmss_trn/test/ss`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}