$re = '/[^\/]*(?:_prd|_trn)/m';
$str = '/test/xychcm_prd/test/ss
/test/xychcmss_trn/test/ss';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);