re = /[^\/]*(?:_prd|_trn)/m
str = '/test/xychcm_prd/test/ss
/test/xychcmss_trn/test/ss'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end