import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b\\w+\\b)([ ]+\\1\\b)+";
final String string = "the little cat cat is in the hat hat hat, we like it.\n"
+ "the little cat cat is in the hat hat hat, we like it.\n"
+ "the little cat cat is in the hat hat hat, we like it.\n"
+ "the little cat cat is in the hat hat hat, we like it.\n"
+ "the the little cat cat is in the hat hat hat, we like it.\n"
+ "the the the little cat cat2 is in the hat hat hat2, we like it.\n"
+ "aa abb bc\n"
+ "ab bbc cd dc dc dc eg";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}