import Foundation
let pattern = #"(\b\w+\b)([ ]+\1\b)+"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
the little cat cat is in the hat hat hat, we like it.
the little cat cat is in the hat hat hat, we like it.
the little cat cat is in the hat hat hat, we like it.
the little cat cat is in the hat hat hat, we like it.
the the little cat cat is in the hat hat hat, we like it.
the the the little cat cat2 is in the hat hat hat2, we like it.
aa abb bc
ab bbc cd dc dc dc eg
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)