re = /(\b\w+\b)([ ]+\1\b)+/m
str = 'the little cat cat is in the hat hat hat, we like it.
the little cat cat is in the hat hat hat, we like it.
the little cat cat is in the hat hat hat, we like it.
the little cat cat is in the hat hat hat, we like it.
the the little cat cat is in the hat hat hat, we like it.
the the the little cat cat2 is in the hat hat hat2, we like it.
aa abb bc
ab bbc cd dc dc dc eg'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result