#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\*\*INS(?!Y\*G8).*(?:\n(?!\*\*(?:INS|DMG)).*)*\n\*\*DMG.*"
Local $sString = "INS*Y*G8*030**A***AC~" & @CRLF & _
"REF*0F*XXXXXXXX~" & @CRLF & _
"NM1*IL*1*JWHWWWW*TWDD****34*XXXXXXXXX~" & @CRLF & _
"N3*45874 WHYYWYW WTWYXW~" & @CRLF & _
"N4*DYXWHXVYW*NY*88980~" & @CRLF & _
"DMG*D8*19700101*M~" & @CRLF & _
"**INS*Y*01*030**A***AC~**" & @CRLF & _
"REF*0F*XXXXXXXXX~" & @CRLF & _
"NM1*IL*1*JWHWWWW*RRWTW****34*XXXXXXXXX~" & @CRLF & _
"PER*IP**TE*XXXXXXXXX*AP*XXXXXXXXX~" & @CRLF & _
"N3*45874 WHYYWYW WTWYXW~" & @CRLF & _
"N4*DYXWHXVYW*NY*88980~" & @CRLF & _
"**DMG*D8*20000101*F~**" & @CRLF & _
"**INS*Y*19*030**A***AC~**" & @CRLF & _
"REF*0F*XXXXXXXXX~" & @CRLF & _
"NM1*IL*1*JWHWWWW*GGDFS****34*XXXXXXXXX~" & @CRLF & _
"PER*IP**TE*XXXXXXXXX*AP*XXXXXXXXX~" & @CRLF & _
"N3*45874 WHYYWYW WTWYXW~" & @CRLF & _
"N4*DYXWHXVYW*NY*88980~" & @CRLF & _
"**DMG*D8*20000101*F~**" & @CRLF & _
"AMT*D2*100~" & @CRLF & _
"AMT*FK*100~" & @CRLF & _
"AMT*R*50~" & @CRLF & _
"AMT*C1*30~" & @CRLF & _
"AMT*P3*31~" & @CRLF & _
"AMT*B9*32~" & @CRLF & _
"NM1*31*1~" & @CRLF & _
"N3*45874 WHYYWYW WTWYXW~" & @CRLF & _
"N4*DYXWHXVYW*NY*88980~"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")