import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "^\\*\\*INS(?!Y\\*G8).*(?:\\n(?!\\*\\*(?:INS|DMG)).*)*\\n\\*\\*DMG.*";
        final String string = "INS*Y*G8*030**A***AC~\n"
	 + "REF*0F*XXXXXXXX~\n"
	 + "NM1*IL*1*JWHWWWW*TWDD****34*XXXXXXXXX~\n"
	 + "N3*45874 WHYYWYW WTWYXW~\n"
	 + "N4*DYXWHXVYW*NY*88980~\n"
	 + "DMG*D8*19700101*M~\n"
	 + "**INS*Y*01*030**A***AC~**\n"
	 + "REF*0F*XXXXXXXXX~\n"
	 + "NM1*IL*1*JWHWWWW*RRWTW****34*XXXXXXXXX~\n"
	 + "PER*IP**TE*XXXXXXXXX*AP*XXXXXXXXX~\n"
	 + "N3*45874 WHYYWYW WTWYXW~\n"
	 + "N4*DYXWHXVYW*NY*88980~\n"
	 + "**DMG*D8*20000101*F~**\n"
	 + "**INS*Y*19*030**A***AC~**\n"
	 + "REF*0F*XXXXXXXXX~\n"
	 + "NM1*IL*1*JWHWWWW*GGDFS****34*XXXXXXXXX~\n"
	 + "PER*IP**TE*XXXXXXXXX*AP*XXXXXXXXX~\n"
	 + "N3*45874 WHYYWYW WTWYXW~\n"
	 + "N4*DYXWHXVYW*NY*88980~\n"
	 + "**DMG*D8*20000101*F~**\n"
	 + "AMT*D2*100~\n"
	 + "AMT*FK*100~\n"
	 + "AMT*R*50~\n"
	 + "AMT*C1*30~\n"
	 + "AMT*P3*31~\n"
	 + "AMT*B9*32~\n"
	 + "NM1*31*1~\n"
	 + "N3*45874 WHYYWYW WTWYXW~\n"
	 + "N4*DYXWHXVYW*NY*88980~";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}