# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\*\*INS(?!Y\*G8).*(?:\n(?!\*\*(?:INS|DMG)).*)*\n\*\*DMG.*"
test_str = ("INS*Y*G8*030**A***AC~\n"
"REF*0F*XXXXXXXX~\n"
"NM1*IL*1*JWHWWWW*TWDD****34*XXXXXXXXX~\n"
"N3*45874 WHYYWYW WTWYXW~\n"
"N4*DYXWHXVYW*NY*88980~\n"
"DMG*D8*19700101*M~\n"
"**INS*Y*01*030**A***AC~**\n"
"REF*0F*XXXXXXXXX~\n"
"NM1*IL*1*JWHWWWW*RRWTW****34*XXXXXXXXX~\n"
"PER*IP**TE*XXXXXXXXX*AP*XXXXXXXXX~\n"
"N3*45874 WHYYWYW WTWYXW~\n"
"N4*DYXWHXVYW*NY*88980~\n"
"**DMG*D8*20000101*F~**\n"
"**INS*Y*19*030**A***AC~**\n"
"REF*0F*XXXXXXXXX~\n"
"NM1*IL*1*JWHWWWW*GGDFS****34*XXXXXXXXX~\n"
"PER*IP**TE*XXXXXXXXX*AP*XXXXXXXXX~\n"
"N3*45874 WHYYWYW WTWYXW~\n"
"N4*DYXWHXVYW*NY*88980~\n"
"**DMG*D8*20000101*F~**\n"
"AMT*D2*100~\n"
"AMT*FK*100~\n"
"AMT*R*50~\n"
"AMT*C1*30~\n"
"AMT*P3*31~\n"
"AMT*B9*32~\n"
"NM1*31*1~\n"
"N3*45874 WHYYWYW WTWYXW~\n"
"N4*DYXWHXVYW*NY*88980~")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.