#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:^|, )\d+(?=\s*[A-Z])"
Local $sString = "1John Radcliffe Hospital/Oxford/United Kingdom, 11Ruhr-Universität " & @CRLF & _
"3/Bochum/Bochum/Germany, 3University of British Columbia/Vancouver/Canada, 4National " & @CRLF & _
"Institute of Neuroscience, National Center of Neurology and Psychiatry/Tokyo/Japan, " & @CRLF & _
"5University of Catania/Catania/Italy, 6F. Hoffmann-La Roche Ltd/Basel/Switzerland, 7 " & @CRLF & _
"University of Colorado School of Medicine/Aurora/United States of America"
Local $sSubst = "\g<0>="
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)