use strict;
my $str = '1John Radcliffe Hospital/Oxford/United Kingdom, 11Ruhr-Universität
3/Bochum/Bochum/Germany, 3University of British Columbia/Vancouver/Canada, 4National
Institute of Neuroscience, National Center of Neurology and Psychiatry/Tokyo/Japan,
5University of Catania/Catania/Italy, 6F. Hoffmann-La Roche Ltd/Basel/Switzerland, 7
University of Colorado School of Medicine/Aurora/United States of America';
my $regex = qr/(?:^|, )\d+(?=\s*[A-Z])/mp;
my $subst = '\\g<0>=';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";