import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|, )\\d+(?=\\s*[A-Z])";
final String string = "1John Radcliffe Hospital/Oxford/United Kingdom, 11Ruhr-Universität \n"
+ "3/Bochum/Bochum/Germany, 3University of British Columbia/Vancouver/Canada, 4National \n"
+ "Institute of Neuroscience, National Center of Neurology and Psychiatry/Tokyo/Japan, \n"
+ "5University of Catania/Catania/Italy, 6F. Hoffmann-La Roche Ltd/Basel/Switzerland, 7 \n"
+ "University of Colorado School of Medicine/Aurora/United States of America";
final String subst = "\\g<0>=";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}