import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=[^\\n\\d]*\\d)(?=\\h*\\S+\\h+\\S)(?=[^A-Z\\n]*[A-Z])(?:[^a-z\\n]*[a-z]){2}.*";
final String string = "112 N Main\n\n"
+ "3525 Webster\n\n"
+ "1 Stone Ave\n\n"
+ "Morrison Number 34";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}