re = /^(?=[^\n\d]*\d)(?=\h*\S+\h+\S)(?=[^A-Z\n]*[A-Z])(?:[^a-z\n]*[a-z]){2}.*/m
str = '112 N Main
3525 Webster
1 Stone Ave
Morrison Number 34'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end