$re = '/^(?=[^\n\d]*\d)(?=\h*\S+\h+\S)(?=[^A-Z\n]*[A-Z])(?:[^a-z\n]*[a-z]){2}.*/m';
$str = '112 N Main
3525 Webster
1 Stone Ave
Morrison Number 34';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);