package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)construit \w{2,4} (lieu|sein|plusieurs|parpaings|face|forme|immeuble|(\d+|\w{2,10}) ([ée]tapes|phases)|ossature|siporex|plaques|charpente|rez.*|rdc|cloison|\d+ fois|r\+\d+)`)
var str = `[NE PAS TENIR COMPTE]
construit en lieu
construit en plusieurs
construit en parpaings
construit en face
construit en forme
construit en immeuble
construit en deux étapes
construit en ossature
construit en siporex
construit en plaques béton
construit en charpente
construit en rez-de-chaussé
construit en 2 phases
construit en cloison
construit en 3 fois
construit en r+1
construit en lieu
construit au sein d'un complexe
construit sur une parcelle`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}