import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "construit \\w{2,4} (lieu|sein|plusieurs|parpaings|face|forme|immeuble|(\\d+|\\w{2,10}) ([ée]tapes|phases)|ossature|siporex|plaques|charpente|rez.*|rdc|cloison|\\d+ fois|r\\+\\d+)";
final String string = "[NE PAS TENIR COMPTE]\n"
+ "construit en lieu\n"
+ "construit en plusieurs\n"
+ "construit en parpaings\n"
+ "construit en face\n"
+ "construit en forme\n"
+ "construit en immeuble\n"
+ "construit en deux étapes\n"
+ "construit en ossature\n"
+ "construit en siporex\n"
+ "construit en plaques béton\n"
+ "construit en charpente \n"
+ "construit en rez-de-chaussé\n"
+ "construit en 2 phases\n"
+ "construit en cloison\n"
+ "construit en 3 fois \n"
+ "construit en r+1 \n"
+ "construit en lieu\n\n"
+ "construit au sein d'un complexe\n"
+ "construit sur une parcelle";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}