using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?://[^,\s]+,?";
string substitution = @"";
string input = @"https://vk.com/wall505680146_2821,id505680146,социальные сети";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}