const regex = new RegExp('https?://[^,\\s]+,?', 'gm')
const str = `https://vk.com/wall505680146_2821,id505680146,социальные сети`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);