import re
regex = re.compile(r"https?://[^,\s]+,?", flags=re.MULTILINE)
test_str = "https://vk.com/wall505680146_2821,id505680146,социальные сети"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)