package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?|((?:
m(?=a)
|(?<=m)a
|a(?=x)
|(?<=a)x
|x(?=m)
|(?<=x)m
|m(?=u)
|(?<=m)u
|u(?=s)
|(?<=u)s
|s(?=t)
|(?<=s)t
|t(?=e)
|(?<=t)e
|e(?=r)
|(?<=e)r
)+)|([maxmuster]))`)
var str = `maxmx dfgdfg
Mymaxmusis
Lemdfgudf
muster
mustr
zxmus
stackoverflow`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}