using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(machine learning|python|neural networks|c)\b";
string input = @"In general: Support us in topics related to machine learning/artificial intelligence, i.e. algorithm development, data preparation and processing in Python, C or C++, neural network training, deployment of neural networks for real-time execution, visualization of results, generation of performance statistics etc.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}