$re = '/\b(machine learning|python|neural networks|c)\b/mi';
$str = 'In general: Support us in topics related to machine learning/artificial intelligence, i.e. algorithm development, data preparation and processing in Python, C or C++, neural network training, deployment of neural networks for real-time execution, visualization of results, generation of performance statistics etc.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);