import re
regex = re.compile(r"\b(machine learning|python|neural networks|c)\b", flags=re.MULTILINE | re.IGNORECASE)
test_str = "In general: Support us in topics related to machine learning/artificial intelligence, i.e. algorithm development, data preparation and processing in Python, C or C++, neural network training, deployment of neural networks for real-time execution, visualization of results, generation of performance statistics etc."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")