$re = '/.*-\d+\.css$/m';
$str = 'cssfile/1e4d2f56-f2c9-45b3-8304-04f4675c8a6f/bootstrap.css';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);