package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?:\/\/\w+(?:[.-]\w+)*(?::[0-9]+)?\/?$`)
var str = `http://www.test-test-test.com
http://www.test.com
http://www.test-.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}