$re = '/^https?:\/\/\w+(?:[.-]\w+)*(?::[0-9]+)?\/?$/m';
$str = 'http://www.test-test-test.com
http://www.test.com
http://www.test-.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);