re = /^https?:\/\/\w+(?:[.-]\w+)*(?::[0-9]+)?\/?$/m
str = 'http://www.test-test-test.com
http://www.test.com
http://www.test-.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end