import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(-\\S+-)(?!\\S)|(?<!\\S)-\\S+(?![\\S-])|(?<![\\S-])\\S+-(?!\\S)";
final String string = "here are -some- word sub-words -word1 word2- sub-word2 word3- -word4\n"
+ "-word5 example\n"
+ "word6-\n"
+ "word7-\n"
+ "another one -word8\n"
+ "-word9\n"
+ "ms$g-";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}