const regex = new RegExp('(?<!\\S)(-\\S+-)(?!\\S)|(?<!\\S)-\\S+(?![\\S-])|(?<![\\S-])\\S+-(?!\\S)', 'gm')
const str = `here are -some- word sub-words -word1 word2- sub-word2 word3- -word4
-word5 example
word6-
word7-
another one -word8
-word9
ms\$g-`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);