using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Field ""([^""]+)"" argument ""([^""]+)"" of type ""([^""]+)"" is required but not provided\.";
string input = @"Field ""saveUserId"" argument ""idTwo"" of type ""String!"" is required but not provided.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}