$re = '/Field "([^"]+)" argument "([^"]+)" of type "([^"]+)" is required but not provided\./';
$str = 'Field "saveUserId" argument "idTwo" of type "String!" is required but not provided.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);