re = /Field "([^"]+)" argument "([^"]+)" of type "([^"]+)" is required but not provided\./
str = 'Field "saveUserId" argument "idTwo" of type "String!" is required but not provided.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end