package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\w+)?'(?:\w+)?`)
var str = `I've never 'had somebody [redacted-number] [redacted-number] [redacted-number] not. not' you're 123'45`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}